Обратная совместимость в PHP 5.1. Частный взгляд

Джефф Мур (Jeff Moore), один из разработчиков WACT опубликовал свое мнение по поводу обратной совместимости PHP 5.1.
Все началось с того, что в лист рассылки WACT поступила информация о том, что WACT не работает под PHP 5.1 RC1. После небольС?ого исследования этого вопроса, были выявлены некоторые РѕС?ибки PHP, помеченные разработчиками PHP как "ложные РѕС?ибки" (bogus). О некоторых из таких ситуаций Джефф и рассказывает в своем блоге.
В результате, Джефф Мур приходит к выводу, что такие несуразности в вопросах обратной совместимости между некоторыми версиями PHP, а так же невозможность одновременной работы двух версий и приводит к тому, что PHP5 так медленно завоевывает хостинг-площадки. Причем настолько медленно, что по некоторым соображениям, мы сможем наблюдать такой феномен, как переход хостеров с PHP4 сразу на PHP6, как только эта версия появится в стабильном виде.